TrackMania Nations Forever Network Check

Any problem ? Don't panic! We have the solution !

Moderator: TM-Patrol

Posts: 2480
Joined: 13 Aug 2005 10:57
Owned TM-games: all
Manialink(s): racemaniac
Location: Belgium

Re: TrackMania Nations Forever Network Check

Post by Racemaniac » 05 Jun 2010 16:16

doubt it.
what's basically happening, is that something is blocking nadeo's network check, without giving you a chance to unblock it. we've had similar problems with f-secure... and if it only happens from time to time, it's rather hard to tell where the cause is :s
disabling your firewall would be a good test, but i doubt it'll help...
as much as the trackmanias may rule, carmageddon 1 & 2 are still the best games ever :D

Posts: 10
Joined: 03 Jun 2010 18:28
Owned TM-games: TMNF

Re: TrackMania Nations Forever Network Check

Post by westinger34 » 05 Jun 2010 16:40

yea ive tried disabling my firewall, dosent work....Im currently downloading a version of TMNF from GamersHell and ill try that one to see if i get the same problem

highway camper
highway camper
Posts: 1
Joined: 01 Jul 2017 05:22
Owned TM-games: TMNF, TMU

Re: TrackMania Nations Forever Network Check

Post by Froyo » 01 Jul 2017 05:34

Bumping because I'm having this exact same problem.

Downloaded the game from steam, and the same network check message with the grey "Ok" box shows up. Also running windows 7 and have avast - I've tried disabling it, but that has no effect. Only difference between me and westinger34 is that I'm having this problem with United while Nations runs just fine. I recently bought it and was hoping to get the full Trackmania experience, as well as relive some childhood memories, but instead I may have just wasted my money.

I've seen multiple threads on this forum with this problem, most of which have not gotten a single reply. This thread was originally posted 7 years ago. Surely, after that much time, SOMEONE must have found a solution to this problem ... right?

Somehow, avast was blocking online connections, stopping the game from starting. I temporarily uninstalled it, ran TMU, reinstalled it, and everything is good now!

Post Reply