(TMUF) Tried Everything, Others Still Can't See My Car Model

Any problem ? Don't panic! We have the solution !

Moderator: TM-Patrol

Post Reply
User avatar
U8er
pedestrian
pedestrian
Posts: 6
Joined: 15 Oct 2010 05:49
Owned TM-games: TMU

(TMUF) Tried Everything, Others Still Can't See My Car Model

Post by U8er » 25 Oct 2010 00:38

Hello, I recently purchased Trackmania United Forever from the official download source.
One of my main reasons for doing so was so that I could show off custom car models in-game after downloading them from manialink pages with coppers and/or a website called "trackmania Car Park" (http://www.trackmania-carpark.com/)
However, after many, many hours (even then, this is an understatement of how much effort has gone into trying to get this problem solved) of endless searching through the Trackmania forums, reading everything even remotely concerning my problem, creating posts based on the topic in search of answers nothing has worked to get my custom car model to become visible to other players. I've searched every website in existince to do with trackmania and beyond.

I've opened ports on my router for TMUF accordingly based off of the information in the Network tab located in "Configure" from the launch menu of the game and information taken by other eager-to-help trackmania players on the forums. I've placed my files in all of the correct root folders listed based on information gathered from my hours of searching, as my cars show up perfectly on my own screen. I've waited the length of Ten or more 6 minute tracks rotating in the same server and others (this adds up to be an hour+ more waiting time to see if others were just slow with downloading my model, even when there were only a couple of people in the server) with the same group of people, randoms, invited friends and nobody can see anything but my (working and visible) .Gif avatar and a stock, grey stadium car.( there have been times when the same color as my custom model has appeared on a stadium car model to other players)

I've been wary of the fact that some servers do not allow shared content and I have made a point of only racing on servers that allow shared content. I have tried with every model from trackmania car park available, and dozens more from manialinks from the in-game menu. I have setup and tested many .loc files for all of my custom content yet this does nothing to remedy the situation. I suppose it would be worth my while to mention that as well as my custom car models not showing up, when I host a public server, nobody can join it (even though the correct ports have been opened on my router). My custom horns are not audible to anyone else but myself despite them too being placed in the correct folders and being formated to the correct file type (otherwise I wouldnt be able to hear them in-game) with .loc files hosted on an appropriate file hosting site. I have never had an enabled firewall for my computer and have no anti-virus protection software, yet despite that being the case I have added exceptions for TMUF to my (not activated) firewall just to be certain. I'm almost certain that all these problems are due to network issues despite the ports being open. Ports 2350 & 3450, If I've missed any please notify me and I'll let you know how it goes, I wont stop trying anything until its fixed or i might as well have ripped up 40$ in front of my face for no reason as i don't race on anything but stadium tracks still; not to try to guilt anyone into trying to help me this is just a very frustrating problem that I've come across and Nadeo support has been no help. I'll edit this post to notify anyone who has come across it if I get anything to work in the meantime.

So just to summarize what is working and what isnt:
*Custom car model shows up as grey stadium car to all other players even after hours of potential download time has been taken into consideration
*Custom Horn is only audible to myself in game; is heard as default horn to all other players
*Able to create and run private/public server but other players are unable to join in all situations
*Custom Avatar is confirmed to be visible to all players

I run Windows 7 64bit and have my network setup through a Belkin N type router. Here are some screen captures of my custom car models in what is listed to be the correct folders and in-game as well as the file placement of my custom horns:
*http://i.imgur.com/2BUjX.jpg (User>My Documents>Trackmania>Skins>Vehicle>Stadium Car>)
*http://i.imgur.com/iAuwp.jpg (User>My Documents>Trackmania>Skins>Vehicle>CarCommon>)
*http://i.imgur.com/YeFFM.jpg (User>Local Disk (C:) > Program Files (x86)> TMUnitedForever> Gamedata>Skins>Vehicles>Stadium Car)
*http://i.imgur.com/G6Nvk.jpg (Screen capture of an example custom car model being used in-game)
*http://i.imgur.com/fksnv.jpg (User> My Documents>Trackmania>Skins>Horns)

This is the most complete list of information I can think to provide to you at the moment, If there is anything I missed or that needs to be added in order to be more thorough about the issue at hand I would be more than ready and eager to provide it to you.
Please, help me figure out this problem, I would be so grateful for your help enabling me to fully enjoy this great game! I look forward to hearing back from someone.
:1

Cheers from a huge Trackmania fan! :lovetm

Steve_59
speedy pilot
speedy pilot
Posts: 425
Joined: 05 Mar 2008 19:21
Owned TM-games: TMUF

Re: (TMUF) Tried Everything, Others Still Can't See My Car M

Post by Steve_59 » 25 Oct 2010 00:47

Try using http://www.canyouseeme.org/ and enter ports 2350 and 3450.
If that site cannot see your ports then it is likely that your ISP is blocking them as it thinks they are Peer to Peer traffic.
Let us know the status of the ports and we can work from there.
Wham! BAM! Thank you ma'am!

User avatar
U8er
pedestrian
pedestrian
Posts: 6
Joined: 15 Oct 2010 05:49
Owned TM-games: TMU

Re: (TMUF) Tried Everything, Others Still Can't See My Car M

Post by U8er » 25 Oct 2010 02:01

Thank you so much for the helpful reply! :1

I received the following error messages when I tried both ports:

Error: I could not see your service on 192.168.2.6 on port (2350)
Reason: Connection Refused


Error: I could not see your service on 192.168.2.6 on port (3450)
Reason: Connection Refused


I also disabled the firewall on my router, however
since then I've tried various websites that check for the ports specified and they've all come up with the same error telling me that they are closed, So I re-enabled it afterwards.

I just checked out this link: http://en.tm-wiki.org/wiki/Server_Setup and found that it instructs to
fill out the forced server address in the network tab under advanced options in TMUF's launcher with my "external ISP given IP address" and I've done that: http://i.imgur.com/j72Q4.jpg

Sorry for taking awhile to get back to you. You gave me something to run on and I tried those few things listed above while looking into other potential solutions but nothings worked yet.

Edit: reading through portforward.com now, If I come across anything that I find to be useful and use to change any settings I'll post here immediately.

User avatar
El Fuego
solid chaser
solid chaser
Posts: 1097
Joined: 27 Oct 2006 11:00
Owned TM-games: TMUF, TM2 C/S
Location: Nae too far frae Glesgie
Contact:

Re: (TMUF) Tried Everything, Others Still Can't See My Car M

Post by El Fuego » 25 Oct 2010 10:11

Are you testing from within your own network? Have you enabled NAT loopback in your router?

The clue is in the error messages ... 192.168.2.6 is an internal (LAN) address. At the CanYouSeeMe site you need to use your external (WAN) address when testing the ports. :)
Cheers!
.FUEY.
Diary Of A Mad Man

Steve_59
speedy pilot
speedy pilot
Posts: 425
Joined: 05 Mar 2008 19:21
Owned TM-games: TMUF

Re: (TMUF) Tried Everything, Others Still Can't See My Car M

Post by Steve_59 » 25 Oct 2010 21:46

That is very strange because canyouseeme should have determined your routers external address, not a non-routable 192.168.x.x address.
Portforward.com should point you in the right direction.
myipaddress.com should display your ip address as seen by the rest of the internet, it should not be in any of the following ranges, 10.x.x.x, 192.168.x.x or 172.x.x.x
Wham! BAM! Thank you ma'am!

User avatar
Ant
TM-Patrol
TM-Patrol
Posts: 1845
Joined: 01 Dec 2007 17:04
Owned TM-games: TMN, TMUF, TM Wii
Location: London, England
Contact:

Re: (TMUF) Tried Everything, Others Still Can't See My Car M

Post by Ant » 25 Oct 2010 23:54

looking at the paths you posted that you have placed your skins in, they don't look right to me.

You have these:
User>My Documents>Trackmania>Skins>Vehicle>Stadium Car>
User>My Documents>Trackmania>Skins>Vehicle>CarCommon>

Try these:
User>My Documents>TrackMania>Skins>Vehicles>StadiumCar>
User>My Documents>TrackMania>Skins>Vehicles>CarCommon>

The bold parts are what you didn't do, so add an "s" and remove the space - hopefully that will fix it for you.

amistar02
highway camper
highway camper
Posts: 2
Joined: 27 Oct 2010 02:22
Owned TM-games: tmu

Re: (TMUF) Tried Everything, Others Still Can't See My Car M

Post by amistar02 » 29 Oct 2010 00:23

Hello, pedestrian all your situation is exactly mine.
pay united, cars not showed to others players.....
if you solve your problem please contact me , if i find it i'll contact you.
thanks

User avatar
Ant
TM-Patrol
TM-Patrol
Posts: 1845
Joined: 01 Dec 2007 17:04
Owned TM-games: TMN, TMUF, TM Wii
Location: London, England
Contact:

Re: (TMUF) Tried Everything, Others Still Can't See My Car M

Post by Ant » 29 Oct 2010 13:55

Don't wanna try what I said above then ??

Post Reply