Page 1 of 1

Car Skins Not Working!!!!

Posted: 23 Apr 2011 19:29
by AliRemix10
Hi, Im new here and I have a real problem. I wanted to download some skins again, but the problem is I wanted to get them to the install folder (Program Files\TrackMania\Skins\Vehicles). I created a folder CarCommon and put them there, start the game and the models aren't there because I had to get them to the documents on the HDD (C:). So and the problem starts really here, the problem is that my HDD (C:) is only 48GB on space and there is only 5GB left. And I thought I would put the cars If not in ZIP I would create a shortcut and the game doesnt seem to see the shortcuts. I put a whole ZIP file and the game sees it?!?!?!? Like WTF!!! I had a problem with my PC power supply and had to get it to service and they reinstalled the whole PC (wasn't very happy about it) and that idiot put 416GB on (D:) and on (C:) its only 48GB and most the data's the PC keeps are on the (C:) and that's not good. I tryed to delete most of useless datas etc. But It only got me few hundreds MB more space. But still it isn't enough for my quite large TM models colletions (about 500 of those beasts). And all the cars have about 4GB. Can somebody help me how to make the cars work as a shortcut? And not the whole ZIP/RAR or whatever file. :grmblz: :cry: P.S. Very sorry about any mistakes, my English isn't the best I tryed. And I don't have time to look on the internet, so the best way is to use forums.

Re: Car Skins Not Working!!!!

Posted: 24 Apr 2011 08:45
by Zandro
Each car skin can be in its own separate zip file. For example, I have WindBlaster.zip and Lotus Carlton.zip, each with their compressed contents at the roots of the zipfiles, i.e. no folders within the zip file. Both are available at the end of my vehicle selection screen. Those you don't need at a moment's notice don't have to be in the folder, as would be the case if everything must be contained in a single zip file. I also wouldn't be surprised if TM had trouble reading a zip file in excess of 4GB.

As for your space concerns, change your MyDocs location to somewhere on the second partition. Also consider changing your pagefile settings to allocate less space on your C partition for swap, though moving all of it off is not recommended in case of a BSOD and dump information must be written. Alternatively, you can create an NTFS junction link between just your CarCommon folder and one on D if you don't want to risk relocating the entire MyDocs folder (which is done through its properties dialog, NOT by manually moving it). An easy junction link manager is Junction Link Magic.

Re: Car Skins Not Working!!!!

Posted: 24 Apr 2011 09:17
by AliRemix10
Thanks, but I'm not very good at these things, tryed one time and got, BSOD!!! Isn't there any other way? :ftw:

Re: Car Skins Not Working!!!!

Posted: 24 Apr 2011 14:27
by Zandro
Well, there is. You would need to non-destructively resize your partitions. Ever use a Linux bootable Live CD? Get your hands dirty and discover the awesomeness of GParted, or buy a copy of Acronis Disk Director. Beyond this, there needn't be anything else to say on the matter, except that one should always back up all important data before any such disk operation.

Re: Car Skins Not Working!!!!

Posted: 24 Apr 2011 14:44
by AliRemix10
Well, you know what? It's a great idea and maybe I'll try it, but I'm playing TMNF on my notebook so I don't really need it. But I'll try it in the near future. Dirty hands, eh? I always have 'em clean, so maybe it's time to get them dirty! :D But It's really stupid, that the game doesn't see the shortcuts. Any other game sees the shortcuts just fine. What's the big deal? GTA IV I use shortcuts and sees it fine without any trouble. Even my CSS with custom maps is just fine. It's just bullshit (excuse me). It's like the show on YT ''You know what's bullshit?!?!?'' from the AVGN and it's just so funny and true.

Re: Car Skins Not Working!!!!

Posted: 24 Apr 2011 15:21
by Zandro
Shortcuts aren't magical portals like hardlinks or junction points to make a file appear that isn't really there. They are distinct files by themselves, with a file extension .LNK hidden by the Explorer shell. XP shortcuts look like this in hexadecimal|OEM:
Image

Windows Explorer knows what to do with them, but other software would need explicit support written in to make use of them. Otherwise it just finds either an incompatible file it won't do anything with, or no files it expects and decides there's nothing to load.

Unless something happened sometime in Vista/Win7 I don't know about!

AVGN is a hoot. I thought for sure he was retiring during the R.O.B. episode, didn't you? But that's getting off topic.

Re: Car Skins Not Working!!!!

Posted: 24 Apr 2011 16:50
by AliRemix10
Wow, really THX!!! And the Vista and 7 are on the same programming, but there were some big changes... Still they are on the same concept, so it isn't much of a problem.

AVGN had unfinished business with E.T. so I think he won't retire after he is done with it, but still there are alot of games that are just shitty and he has to make them justice!

Re: Car Skins Not Working!!!!

Posted: 25 Apr 2011 18:27
by AliRemix10
WTF is your problem? I want to know if there is any other way to put models to the game there besides the documents... I don't know why only idiots write me replies in my posts (Zandro atleast tryed to help so he's cool)... :|

Re: Car Skins Not Working!!!!

Posted: 25 Apr 2011 19:15
by Xymph
AliRemix10 wrote:WTF is your problem? I want to know if there is any other way to put models to the game there besides the documents... I don't know why only idiots write me replies in my posts (Zandro atleast tryed to help so he's cool)... :|
Don't follow up to (signature) spammers. Ignore them, or use the Report button if someone else already hasn't, and a moderator will eventually deal with it.

Re: Car Skins Not Working!!!!

Posted: 27 Apr 2011 08:53
by Knutselmaaster
In win xp you can use tweak ui (one of microsofts powertools) to set another location for "my documents" (and many other special folders)
This way you can use your D: drive for your custom tm content.
I imagine that there is tweak ui for vista/7 too....

Re: Car Skins Not Working!!!!

Posted: 27 Apr 2011 21:16
by svens
Knutselmaaster wrote:In win xp you can use tweak ui (one of microsofts powertools) to set another location for "my documents" (and many other special folders)
This way you can use your D: drive for your custom tm content.
I imagine that there is tweak ui for vista/7 too....
You can also just right-click the "My Documents" folder (not the library, Microsoft engineers are very good in confusing users) go to Properties and change the location in the "Location" tab (Win 7, similar steps for Vista and even XP). No need for any fancy tools ;).