TrackMania doesn't start/closes itself upon launch

Any problem ? Don't panic! We have the solution !

Moderator: TM-Patrol

Post Reply
SpyKid128
highway camper
highway camper
Posts: 2
Joined: 09 Sep 2015 23:51
Owned TM-games: TMU, TMNF

TrackMania doesn't start/closes itself upon launch

Post by SpyKid128 » 10 Sep 2015 00:01

Hi. I have a problem with my Trackmania. This is related to both games I own, TrackMania United and Nations Forever.
I cannot start these games anymore. When I start the launcher and click on play the window just closes itself and the game with a blank window appears and vanishes 1 second after. It also does NOT show a process in the Task Manager either.

The same thing happens with both. I also tried starting the .exe file only. Same thing. I've been looking around in this forum and some others had my problem, but also their solutions won't work for me, such as run exe as admin or typing tmtp:// in the browser's URL bar, I can also start the game this way, but the same thing happens again, it vanishes. I use Windows XP (I know, it's an old OS...), my graphics card is a Palit Nvidia GeForce GTX560 TI, have an AMD Athlon II Processor with 3.20 ghz and 3.25 GB ram. The game worked for me since years, never had such a problem with it. I also checked the updates, I already have the newest versions. The game is not from Steam, it is installed as stand alone. This is really frustrating ... :( :( I hope I can get a quick answer.

SpyKid128
highway camper
highway camper
Posts: 2
Joined: 09 Sep 2015 23:51
Owned TM-games: TMU, TMNF

Re: TrackMania doesn't start/closes itself upon launch

Post by SpyKid128 » 13 Sep 2015 02:58

Pushing this up because this time I've got a Crash Log.

Code: Select all

TmForever
2.11.26
2010-03-15
[Sys] Os = Microsoft Windows XP(Service Pack 3)
[Sys] Cpu = AMD Athlon(tm) II X3 450 Processor
[Sys] Cpu = 3 199MHz (bench)
[Sys] Physical memory = 3 328 Mb
[Sys] Windows GDI resolution = 1 360x768x32b
[Sys] ExeChecksum = 0x31C17139
[Sys] ---- GlobalMemoryStatus(Startup) ----
[Sys] MemoryLoad = 33%
[Sys] TotalPhys = 3 328 Mb
[Sys] AvailPhys = 2 215 Mb
[Sys] TotalPageFile = 5 237 Mb
[Sys] AvailPageFile = 3 928 Mb
[Sys] TotalVirtual = 2 990 Mb
[Sys] AvailVirtual = 2 940 Mb
[Sys] ----------------------------
[Sys] ---- GlobalMemoryStatus(Now) ----
[Sys] MemoryLoad = 33%
[Sys] TotalPhys = 3 328 Mb
[Sys] AvailPhys = 2 211 Mb
[Sys] TotalPageFile = 5 237 Mb
[Sys] AvailPageFile = 3 926 Mb
[Sys] TotalVirtual = 2 990 Mb
[Sys] AvailVirtual = 2 921 Mb
[Sys] ----------------------------
Win32 Exception : Access violation
	=>Occured at address 0x7C920ED4
	The thread tried to read from the invalid address (data) 0xFFFFFFF7
	eax=0xFFFFFFFF   ebx=0x00160000   ecx=0x000000D8   edx=0x00160608
	edi=0x00000301   esi=0xFFFFFFF7   ebp=0x0013E6F8   esp=0x0013E4D8   eip=0x7C920ED4
	Called from address 0x778F69F8
	Called from address 0x778FAE92
	Called from address 0x778FADFF
	Called from address 0x778FC355
	Called from address 0x6D302A39
	Called from address 0x6D303045
	Called from address 0x6D303DFA
	Called from address 0x6D2F4713
	Called from address 0x6D301124
	Called from address 0x6D2FDD40
	Called from address 0x008FD1A3
End of stack...
[Sys] Time is 4h 48mn 9s 421ms


Stack was copied from 0x0x0013E458, 16 384 bytes
The problem still is the same as above.
I even tried more things I've found on google to solve this:
- Reinstalling the game
- Updating graphic drivers
- Check if a virus blocks the game, removed virus that was found
- Deleted OpenAL program off my computer because apparently it causes a conflict with TrackMania

Did that all and the problem is stil there I want to play the game so much :cry:
Please tell me what else I could do. And I hope the Crash Log helps !!!

Post Reply