I think I bricked TrackMania. Help!

Any problem ? Don't panic! We have the solution !

Moderator: TM-Patrol

Post Reply
User avatar
wheelbarrow operator
wheelbarrow operator
Posts: 22
Joined: 09 Jul 2010 15:13
Owned TM-games: TMSX,TMUF
Location: United States

I think I bricked TrackMania. Help!

Post by SonicFan667 » 12 Feb 2016 03:52

It used to work one time but now, it's not even starting up.

So back in April of last year, I was introduced to this new thing called Reshade, which allows different kinds of shaders to be added in a game seamlessly, enhancing the graphics. I've decided to give it a go by testing it on Trackmania United.

After that, the result was beautiful and I couldn't stop playing them game in that mode. However, a few months later, in August, Trackmania wouldn't start anymore. When I tried to launch the game, a white screen would pop up but close within seconds. I've found a way to fix the problem by deleting the d3d9.dll files which were overwritten by Reshade.

After that, the game worked fine... at least for a month. If I try to play the game now, it would completely freeze up forever once it's done loading up. The same went with Maniaplanet which was also Reshade'd. I was like "Maybe this is just a computer problem. I'll just restart."

After restarting, nothing even changed! I tried reinstalling Trackmania United, but that still didn't work. I switched between installing the standalone version and the Steam version seeing if they would work, but I ended up uninstalling them both to work with the standalone version.

I think it's because my d3d9.dll files in the game's directory seem to be corrupted.
I tried that out through several experiments and I've came to a conclusion.

The game starts up if I remove the .dll files from the folder, but it won't get any further than that. It just freezes permanently and I had to close it through the Task Manager. However, if I kept the .dll files, the game wouldn't start up at all.

Besides that, I've tried verifying the integrity of the cache (because I have the Steam version), and restarting my computer, but none of that worked.

Could somebody help me figure this out?

-Game name: Trackmania United Forever and Maniaplanet
-System: Intel(R) Core i3-2120 CPU, Nvidia GeForce GT 640, 8 GB of RAM
-Log file: none
-Error messages: none
-Action: Simply nothing, I just launch the game.
gatta go fest

Post Reply