Mouse/Keyboard won't function when controller plugged in

Any problem ? Don't panic! We have the solution !

Moderator: TM-Patrol

Post Reply
Boastful Toast
highway camper
highway camper
Posts: 1
Joined: 04 Mar 2016 23:51
Owned TM-games: TMU, TMNF

Mouse/Keyboard won't function when controller plugged in

Post by Boastful Toast » 04 Mar 2016 23:58

After all the hoops I had to jump through (patches/downloads/fixes) to get TMUF to work, just recently now my mouse+kb will not work in game. I can highlight things with my mouse, but cannot click.

I read a ton of other forum posts about this, and the only one that was resolved was relating to a g5 mouse and saitek kb, neither of which I own.


gtx 970
Win 10
Razer Taipan Mouse
Xb1 controller
Razer Blackwidow KB

Haven't had this problem until very recently, but TM is literally unplayable, so any support would be great ty!

highway camper
highway camper
Posts: 1
Joined: 30 Mar 2016 14:05
Owned TM-games: TMU, TMS

Re: Mouse/Keyboard won't function when controller plugged in

Post by summat » 30 Mar 2016 14:12

I'm having EXACTLY this issue on windows 10.

It started when MS released a cumulative update (KB3140743) at the start of March. Ever since then, the keyboard hasn't worked in game, and the mouse can only point, not click.

Removing the above update does bring it back to working - but given the cumulative updates can include fixes for windows, it's not exactly an option to never install it. Plus there will only end up being another cumulative update later which would break it again (and already did, KB3140768).

I have an XBox One controller connected - this works within the game okay, but lack of keyboard/mouse working is a real problem, and makes it unplayable for me. I play multiplayer and need to be able to chat in game.

I have found that unplugging the controller before starting the game will allow the keyboard and mouse to work normally, but given I use the controller to control the car, that doesn't help me either. Plugging the controller in once the game has started doesn't allow the controller to work.

Sys spec:

i7 4790K
16GB mem
Win10 x64 Pro

Edit: I've also tried using the processor graphics instead of my nvidia card, and it made no difference when running on Intel graphics, so I don't think its a graphics problem.

Post Reply