Aseco Fatal Error

This forum is dedicated to the Aseco/Rasp 2 server records and control script by Flo and Assembler Maniac. Announcements and issues can be discussed in this forum.

Moderators: Flo, f*ckfish, Assembler Maniac, TM-Patrol

Post Reply
Atomaffe
highway camper
highway camper
Posts: 2
Joined: 22 May 2008 17:02
Owned TM-games: TMF

Aseco Fatal Error

Post by Atomaffe » 22 May 2008 17:08

Hello, my problem is this:

Code: Select all

# initialize ASECO ############################################################
[Aseco] PHP Version is 5.2.6
[Aseco] Load settings [config.xml]
###############################################################################
#
# Aseco v2.1.4 running on 127.0.0.1:5001
#
# Authors: Florian Schnell and Brad Mettee (RASP)
#
###############################################################################
[Load Plugin] [plugin.tmxlinker.php] [Name:TmxLinker] [Ver:1]
[Load Plugin] [plugin.about.php] [Name:About] [Ver:1]
[Load Plugin] [plugin.statusbar.php] [Name:Statusbar] [Ver:1]
[Load Plugin] [plugin.stats.php] [Name:Stats] [Ver:1]
[Load Plugin] [plugin.records.php] [Name:Records] [Ver:1]
[Load Plugin] [plugin.vote.php] [Name:Vote] [Ver:1]
[Load Plugin] [plugin.score.php] [Name:Score] [Ver:1]
[Load Plugin] [plugin.example.php] [Name:Example] [Ver:1]
[Load Plugin] [plugin.help.php] [Name:Help] [Ver:1]
[Load Plugin] [plugin.emotics.php] [Name:Emotics] [Ver:1]
[Load Plugin] [plugin.pubdb.php] [Name:PubDb] [Ver:1]
[Load Plugin] [plugin.admin.php] [Name:Admin] [Ver:1]
[Load Plugin] [plugin.plugins.php] [Name:Plugins] [Ver:1]
No authitems added
[Aseco] Try to connect to server on 127.0.0.1:5001
[Aseco] Authenticated with username 'SuperAdmin' and password 'XXXXXX'
[Aseco] Connection established successfully!
[PubDb] Load settings file ...
[PubDb] Connecting to Public Database Server ...

Fatal error: Class 'mysqli' not found in /home/teamexe1/aseco/plugins/plugin.pubdb.php on line 21
[05/22,18:39:55] Beginning to shutdown Aseco due to an error ...
I get a fatal error and dont know what i do wrong.
Please help me.

Assembler Maniac
Pit Crew
Pit Crew
Posts: 1493
Joined: 03 Jun 2006 13:24
Owned TM-games: TMU
Contact:

Re: Aseco Fatal Error

Post by Assembler Maniac » 22 May 2008 17:58

Edit php.ini, search for mysqli in the extensions section. If there's a ; in front of it, remove it, it just means the module isn't loaded.

Atomaffe wrote:Hello, my problem is this:

Code: Select all

# initialize ASECO ############################################################
[Aseco] PHP Version is 5.2.6
[Aseco] Load settings [config.xml]
###############################################################################
#
# Aseco v2.1.4 running on 127.0.0.1:5001
#
# Authors: Florian Schnell and Brad Mettee (RASP)
#
###############################################################################
[Load Plugin] [plugin.tmxlinker.php] [Name:TmxLinker] [Ver:1]
[Load Plugin] [plugin.about.php] [Name:About] [Ver:1]
[Load Plugin] [plugin.statusbar.php] [Name:Statusbar] [Ver:1]
[Load Plugin] [plugin.stats.php] [Name:Stats] [Ver:1]
[Load Plugin] [plugin.records.php] [Name:Records] [Ver:1]
[Load Plugin] [plugin.vote.php] [Name:Vote] [Ver:1]
[Load Plugin] [plugin.score.php] [Name:Score] [Ver:1]
[Load Plugin] [plugin.example.php] [Name:Example] [Ver:1]
[Load Plugin] [plugin.help.php] [Name:Help] [Ver:1]
[Load Plugin] [plugin.emotics.php] [Name:Emotics] [Ver:1]
[Load Plugin] [plugin.pubdb.php] [Name:PubDb] [Ver:1]
[Load Plugin] [plugin.admin.php] [Name:Admin] [Ver:1]
[Load Plugin] [plugin.plugins.php] [Name:Plugins] [Ver:1]
No authitems added
[Aseco] Try to connect to server on 127.0.0.1:5001
[Aseco] Authenticated with username 'SuperAdmin' and password 'XXXXXX'
[Aseco] Connection established successfully!
[PubDb] Load settings file ...
[PubDb] Connecting to Public Database Server ...

Fatal error: Class 'mysqli' not found in /home/teamexe1/aseco/plugins/plugin.pubdb.php on line 21
[05/22,18:39:55] Beginning to shutdown Aseco due to an error ...
I get a fatal error and dont know what i do wrong.
Please help me.

Atomaffe
highway camper
highway camper
Posts: 2
Joined: 22 May 2008 17:02
Owned TM-games: TMF

Re: Aseco Fatal Error

Post by Atomaffe » 23 May 2008 11:16

no thats not the error. because there is no ;

Assembler Maniac
Pit Crew
Pit Crew
Posts: 1493
Joined: 03 Jun 2006 13:24
Owned TM-games: TMU
Contact:

Re: Aseco Fatal Error

Post by Assembler Maniac » 23 May 2008 12:30

Atomaffe wrote:no thats not the error. because there is no ;
Ok, the mysqli class being not found means that PHP is not configured to use mysqli.

What version of php are you using?

User avatar
oliverde8
solid chaser
solid chaser
Posts: 1135
Joined: 07 Oct 2006 07:03
Owned TM-games: TMU
Manialink(s): oliverde8
Location: Turkey
Contact:

Re: Aseco Fatal Error

Post by oliverde8 » 23 May 2008 13:52

he is using 5.2.6 :D it written in his log :roll:
ImageImage
Manialink : oliverde8color>
Servers : STATS <> United | VeryShort | Made In Turkey

Assembler Maniac
Pit Crew
Pit Crew
Posts: 1493
Joined: 03 Jun 2006 13:24
Owned TM-games: TMU
Contact:

Re: Aseco Fatal Error

Post by Assembler Maniac » 23 May 2008 14:11

oliverde8 wrote:he is using 5.2.6 :D it written in his log :roll:
Sorry, wrong question then.

I need to know what OS it's on. How did he install the PHP version he's using, and if it's compiled without mysqli support, or if it's just not configured right.

We've had some other people that found out there were multiple versions of php.ini on their machines and it wasn't reading from the php.ini that looked like it was ok.

Post Reply