Page 1 of 1

Fatal error:

Posted: 21 Oct 2009 14:27
by penguisher
Hello everyone,

I followed the instructions on TMBase.de for remoteCP 4.
after setting the permissions to 771 i get this error:

Code: Select all

Fatal error: Uncaught exception 'Exception' with message 'String could not be parsed as XML' in /var/www/tm/includes/core/rcp_session.class.php:23 Stack trace: #0 /var/www/tm/includes/core/rcp_session.class.php(23): SimpleXMLElement->__construct('./xml/admins.xm...', 0, true) #1 /var/www/tm/includes/core.class.php(149): rcp_session->__construct(Object(Core)) #2 /var/www/tm/includes/core.class.php(97): Core->storeObject('core/rcp_sessio...', 'rcp_session', 'session') #3 /var/www/tm/index.php(18): Core::storeCoreObjects() #4 {main} thrown in /var/www/tm/includes/core/rcp_session.class.php on line 23
From which file(s) should I change the permission to make it work again. I would like to keep this control panel safe too, so to what should I set the permissions?

Re: Fatal error:

Posted: 21 Oct 2009 14:36
by hal|Sascha
hi,

I think this isn't a problem with permissions its a invalid xml file. Check your servers.xml oder admins.xml if it contains invalid xml code or post them here (without passwords).

Sascha

Re: Fatal error:

Posted: 21 Oct 2009 15:17
by penguisher
Ok, here ar my xml files. I can't find wrong code, but probably I think I missed it.

admin.xml

Code: Select all

<?xml version="1.0"?>
<admins>
	<admin>
		<id>L1</id>
		<active>true</active>
		<group>1</group>
		<servers>
			<id>1</id>
		</servers>
		<username>rcplive</username>
		<password></password>
		<nocode>false</nocode>
		<tmaccount>false</tmaccount>
		<language>en</language>
		<style>default</style>
	</admin>
	<admin>
		<id>G1</id>
		<active>true</active>
		<group>G1</group>
		<servers>
			<id>1</id>
		</servers>
		<username>Guest</username>
		<password></password>
		<nocode>false</nocode>
		<tmaccount>false</tmaccount>
		<language>en</language>
		<style>default</style>
	</admin>
	<admin>
		<id>1</id>
		<active>true</active>
		<group>1</group>
		<servers>
			<id>1</id>
		</servers>
		<username>admin</username>
		<password></password>
		<nocode>false</nocode>
		<tmaccount>false</tmaccount>
		<language>en</language>
		<style>default</style>
	</admin>
</admins>
servers.xml:

Code: Select all

<?xml version="1.0" encoding="utf-8"?>
<servers>
	<server>
		<id>1</id>
		<login>penguisherfunpark</login>
		<name>Penguisher FunPark</name>
		<settingset></settingset>			<!-- Pathname without slashes, leave empty for default settings -->
		<filepath></filepath>				<!-- Pathname without slashes, leave empty for old remoteCP3 style -->
		<connection>
			<ip>localhost</ip>
			<port>5000</port>
			<account>SuperAdmin</account>
			<password></password>
		</connection>
		<ftp enabled='false'>
			<host>localhost</host>
			<port></port>					<!-- leave empty for default port 21 -->
			<username>username</username>
			<password>password</password>
			<path>/GameData/Tracks/</path>
		</ftp>
		<sql enabled='false'>
			<type>mysql</type>
			<host>localhost</host>
			<username>username</username>
			<password>password</password>
			<dbname>remotecp</dbname>
		</sql>
		<lists>
			<guestlist>guestlist.txt</guestlist>
			<blacklist>blacklist.txt</blacklist>
		</lists>
	</server>
</servers>

Re: Fatal error:

Posted: 21 Oct 2009 17:06
by penguisher
I figured out that if I set the permissions of those xml files to 777 I do get the control panel. But As I was told in another topic the chmod 777 is not safe. You said something about .htacces files too, is there a way to check if that .htacces is working?