Page 1 of 1

Fatal Error

Posted: 16 Feb 2010 10:38
by virusx
Hi everyone,
Firstly, RemoteCP4 has been correctly installed, but I have a problem when I try to run the _live.bat, here is the message I have:
Fatal error: Call to a member function prepare() on a non-object in C:\Program Files\EasyPHP5.3.0\www\remotecp\live\Ladder\index.php on line 27
the instruction at this line is supposed to create a table 'rcp_ladder_serverid' in the database...
What should I do to fix this problem?

Re: Fatal Error

Posted: 16 Feb 2010 13:43
by virusx
no one ??

Re: Fatal Error

Posted: 16 Feb 2010 15:34
by Xymph
Never bump your posts within one day, or even a week. We're not all here sitting 24/7 waiting to answer your posts ya know. :wink:
And no, I don't use RCP so I have no idea.

Re: Fatal Error

Posted: 16 Feb 2010 15:38
by jamie_macdonald
firstly i would check your version of php/apache server. i think there are more recent that 5.3.x ?

that would explain getting a bad call if the commands in php have changed slightly in the newer versions.

all i can suggest as i dont know much more than that myself.


Good Luck ^^

Re: Fatal Error

Posted: 16 Feb 2010 15:54
by Lambda
RemoteCP - Documentation: tmbase

Re: Fatal Error

Posted: 16 Feb 2010 16:01
by corto-72
It seems there is a problem connecting to the database (the $db object not being created on line 25 ) Do you have any other errors before that fatal error?

Note that the 'prepare' function is linked to php_pdo module - allowing a generic way of handling database connection / communication (i.e. irrespective of the type of DB, mysql, sql_lite, etc...)
Do you have this php_pdo module activated?

Re: Fatal Error

Posted: 08 Jan 2011 11:47
by Longi94
I get the same error, I followed the instruction on http://www.tmbase.de/V6/docs/install4/
And my servers.xml looks like this:

Code: Select all

<?xml version="1.0" encoding="utf-8"?>
<servers>
	<server>
		<id>1</id>
		<login>electro-shock</login>
		<name>ElectroShock</name>
		<settingset></settingset>			<!-- Pathname without slashes, leave empty for default settings -->
		<filepath></filepath>				<!-- Pathname without slashes, leave empty for default filepath -->
		<connection>
			<host>127.0.0.1</host>
			<port>5071</port>
			<password>SuperAdmin</password>
			<communitycode>000000</communitycode>
		</connection>
		<ftp enabled='false'>
			<host>127.0.0.1</host>
			<port></port>					<!-- leave empty for default port 21 -->
			<username>Admin</username>
			<password></password>
			<path>/GameData/Tracks/</path>
		</ftp>
		<sql enabled='false'>
			<dsn>mysql:dbname=remotecp;host=127.0.0.1</dsn>
			<username>root</username>
			<password></password>
		</sql>
		<lists>
			<guestlist>guestlist.txt</guestlist>
			<blacklist>blacklist.txt</blacklist>
		</lists>
	</server>
</servers>
I use xampp and it has the 5.3.1 version of PHP.

Re: Fatal Error

Posted: 01 Feb 2011 06:58
by nocturne
I have no idea whether or not rcp4 is coded to work fine on php5.3 (not willing to test it myself)... It's still a dev version, and is nowhere near as lax as php 5.2x on coding.

Though of a more obvious note... you could always try setting <sql enabled='false'> to <sql enabled='true'>...

Re: Fatal Error

Posted: 01 Feb 2011 13:38
by svens
I've no had no issues with rcp4 and PHP 5.3.3-7 on my test machine (yet). However, I don't use (and didn't test) Live.

http://www.tmbase.de/ itself seems to have some problems with it...

@Longi: You should censor your passwords in the servers.xml.