map color codes bugging in title

Discover FAST, a records keeping server control script with a public records system called Dedimania, which will show records from the server on tm-exchange.com

Moderators: Slig, TM-Patrol

Post Reply
*Garfield
pedestrian
pedestrian
Posts: 13
Joined: 08 Aug 2011 04:15
Owned TM-games: TMO, TMUF

map color codes bugging in title

Post by *Garfield » 13 Aug 2011 18:17

Hello again, I just have one more problem with the Fast3.2.2x program. For some reason, in the corner of the screen, where the title is, the color codes won't work like regular :( Here is an example.

Image

The title looks completely screwed up ^^

Anyone know a solution to this ?

Xymph
Pit Crew
Pit Crew
Posts: 5650
Joined: 19 Aug 2007 12:58
Owned TM-games: TMN, TMU, TMF, TM²
Contact:

Re: map color codes bugging in title

Post by Xymph » 13 Aug 2011 18:23

Don't post your Fast question in the ServerMania forum again, they belong in the Fast forum.
Now a moderator has to move this topic again. :evil:
Developer of XASECO for TMF/TMN ESWC & XASECO2 for TM²: see XAseco.org
Find your way around the Mania community from the TMN ESWC hub, TMF hub, TM² hub, and SM hub

*Garfield
pedestrian
pedestrian
Posts: 13
Joined: 08 Aug 2011 04:15
Owned TM-games: TMO, TMUF

Re: map color codes bugging in title

Post by *Garfield » 14 Aug 2011 03:54

Don't freak out...I assumed FAST was the main plugin for servermania so I thought it was the same.

User avatar
Slig
Pit Crew
Pit Crew
Posts: 2124
Joined: 05 Sep 2005 17:51
Owned TM-games: ALL
Location: TraxicoLand (Fr)
Contact:

Re: map color codes bugging in title

Post by Slig » 14 Aug 2011 13:26

Without the map to check what is really its name it is difficult answer.
I guess that the map use some wrong/improper color codes, or wrong utf8 chars, which are badly filtered.

And btw non, it's not the same : most time i won't read topics in other tools subforums except if the title make me curious. Here you are lucky that i read it. ;)

*Garfield
pedestrian
pedestrian
Posts: 13
Joined: 08 Aug 2011 04:15
Owned TM-games: TMO, TMUF

Re: map color codes bugging in title

Post by *Garfield » 17 Aug 2011 16:07

Well it's strange because if I remove the FAST plugin and I just let servermania run, the titles are perfectly fixed like normal ^^

User avatar
Slig
Pit Crew
Pit Crew
Posts: 2124
Joined: 05 Sep 2005 17:51
Owned TM-games: ALL
Location: TraxicoLand (Fr)
Contact:

Re: map color codes bugging in title

Post by Slig » 17 Aug 2011 17:31

In such game it's the game which show it, not the script using manialinks.
The game is sadly far too permissive with strange color codes and bad utf8 codes, while bad utf8 codes are rejected when sent in manialinks.
Have you a link to the map ? i'm interested to check the name really set in it.

*Garfield
pedestrian
pedestrian
Posts: 13
Joined: 08 Aug 2011 04:15
Owned TM-games: TMO, TMUF

Re: map color codes bugging in title

Post by *Garfield » 22 Aug 2011 03:12

Well a few maps seem to do this, but I'll give you the link to the map I showed earlier.

http://united.tm-exchange.com/main.aspx ... 36060#auto

User avatar
Slig
Pit Crew
Pit Crew
Posts: 2124
Joined: 05 Sep 2005 17:51
Owned TM-games: ALL
Location: TraxicoLand (Fr)
Contact:

Re: map color codes bugging in title

Post by Slig » 22 Aug 2011 17:34

ok, so the name of that map :

Code: Select all

$i$o$s$w$cqs»$c9hA$cg8k$cccA$c8fm$8faA$c9gru$cxz°
where, various color codes are invalid and just silly !

Code: Select all

$cqs
$c9h
$cg8
$c9g
$cxz
Btw, fast 3.2.2y and 3.2.3 series show the name of that map correctly

Post Reply