Page 1 of 1

Adapt a plugin from a Manialive one

Posted: 19 Apr 2014 15:55
by du02
Hello everyone

Before starting to learn php I would like to know if a Manialive plugin can be adapted for Fast (3.2.3m)
In the php files I can see that Manialib is used, could it be a problem ? Or anything else could be bad to achieve the work ?

Thanks for your help

Re: Adapt a plugin from a Manialive one

Posted: 20 Apr 2014 11:01
by askuri
It would be hard work and depending on how much ManiaLib is used i suggest to completely recode the Plugin.
But you shouöldnt start learning PHP with porting a ManiaLive Pkugin. ManiaLive is extemely complex and even for me with 2 years PHP experience (ok not soo much) sometimes hard to understand. Generally Servercontrollers are more complex then simple Manialinks, escpecially because they use OOP (i suggest you too learn normal procedural coding first).
So start learning wioth something easier. It is although hard enaugh ;)

Re: Adapt a plugin from a Manialive one

Posted: 20 Apr 2014 12:56
by du02
Thank for your reply askuri.

Manialib can be used only with Manialive so ?
I will take a tour on tutorials for beginner, maybe after a couple of months it should be easier. :3

Re: Adapt a plugin from a Manialive one

Posted: 22 Apr 2014 12:02
by askuri
No Manialib can be used anywhere but in my opinion it doesnt make sense to include the huge Manialib for a single plugin :D. That would be possible but a very unclean solution ;)

Re: Adapt a plugin from a Manialive one

Posted: 23 Apr 2014 19:57
by du02
Sounds good. I've started learning php, I'm hopeful and optimistic !