FAST 3.1.3o (2008-03-08) TMS/TMO/oldTMN/oldTMU

Discover FAST, a records keeping server control script with a public records system called Dedimania, which will show records from the server on tm-exchange.com

Moderators: Slig, TM-Patrol

User avatar
Slig
Pit Crew
Pit Crew
Posts: 2124
Joined: 05 Sep 2005 17:51
Owned TM-games: ALL
Location: TraxicoLand (Fr)
Contact:

Post by Slig » 09 Feb 2007 12:56

Hor wrote:I get this message: "You use a LAN connection, and don't have a login for records actually" (in the game chat when i connect to the serv)
Add your real login in the <login> part for your used lan login (ie nickname/ip) in the file LANlogins.tmx.xxx.xml.txt which should have been created. If you change your nickname you will have to add it again because the login for LAN connected is based on it.
Be carefull to spell tour login correctly.

Fisch.666 wrote: is the problem because i can't find the xml_parse_file function in the php functions list:

http://www.php.net/manual-lookup.php?pa ... parse_file

Only the xml_parse function is listened.
that function is in the includes/xml_parser.php. i just noticed that this file begin with '<?' and not '<?php' ! and your php.ini is probably not configured to accept that : try to correct it it will probably be ok.

v22
wheelbarrow operator
wheelbarrow operator
Posts: 15
Joined: 09 May 2006 16:01

help!

Post by v22 » 09 Feb 2007 18:35

Hi!
how fix a problem at the start of script ??


X-Powered-By: PHP/5.1.4
Content-type: text/html; charset=cp1251

[02/09,19:20:05] ##############################################################
[02/09,19:20:05] Connection to TM server: 127.0.0.1:5001
[02/09,19:20:05] *** TMN Server (0.1.7.4,2006-05-30): callback mode. ***
xml_parse_file: can't find file LANlogins.tmn.Xtreme RA Team S2.xml.txt.
[02/09,19:20:05] Loading plugins...
[02/09,19:20:05] ************* (db.0) *************
Dataserver connection on $l[http://dedimania.tm-community.com/tmstats/?do=stat]Dedimania$l ...
!!!!!!
!!!!!! Connection Error !!!!!!
Warning in server.php(106): AuthWarning:
Warning in check_login_tm.php(88): Bad TMN Login Xtreme RA Team S2 !
Error in method_handler.php(226): Not Authenticated
!!!!!!
[02/09,19:20:09] ------------- (db.0) -------------

[02/09,19:20:09] Register chat commands

##############################################
FastNdcl 3.1.1 running on: 127.0.0.1:5001
(c) 2006 by Gilles Masson
Server: TMN, Version: 0.1.7.4, Build: 2006-05-30
Started using php 5.1.4 (/usr/local/bin/php from /home/v22/TM_extreme_ra)
##############################################

[02/09,19:20:09] *********** databaseStartToServe()

[02/09,19:20:09] Starting to serve... (Fri 09 Feb 2007)
[02/09,19:20:09]
**************** Init start ******************
[02/09,19:20:09] **************** Init events ******************
[02/09,19:20:09] *********** databaseStartToServe()
[02/09,19:20:09] players.Event[StatusChanged](4) [old=-1]
xml_parse_file: can't find file LANlogins.tmn.Xtreme RA Team S2.xml.txt.
[02/09,19:20:10] **************** Init end ******************

[02/09,19:20:11] >> Player: marine1996 (marine1996) has connected! (1/20)
[02/09,19:21:17] players.Event[StatusChanged](5) [old=4]
[02/09,19:21:19] *** ChallengeInfo is now Sure : Upside Straight v2.0
[02/09,19:21:19] database.Event[EndRace]('')
[02/09,19:21:36] players.Event[StatusChanged](2) [old=5]
xml_parse_file: can't find file LANlogins.tmn.Xtreme RA Team S2.xml.txt.
[02/09,19:21:38] players.Event[StatusChanged](3) [old=2]
[02/09,19:21:54] players.Event[StatusChanged](4) [old=3]
[02/09,19:23:40] << Player: marine1996 (marine1996) has disconnected! (0/20)

.....

User avatar
Fisch.666
happy cruiser
happy cruiser
Posts: 136
Joined: 18 May 2006 01:13
Owned TM-games: TMU, TMN, TMUF, TMNF
Location: Germany
Contact:

Post by Fisch.666 » 09 Feb 2007 21:02

Hi!
Slig wrote: that function is in the includes/xml_parser.php. i just noticed that this file begin with '<?' and not '<?php' ! and your php.ini is probably not configured to accept that : try to correct it it will probably be ok.
Thanks for this hint. I changed <? to <?php and now fast works without a problem. :D

User avatar
Fisch.666
happy cruiser
happy cruiser
Posts: 136
Joined: 18 May 2006 01:13
Owned TM-games: TMU, TMN, TMUF, TMNF
Location: Germany
Contact:

Post by Fisch.666 » 12 Feb 2007 00:55

Fisch.666 wrote:fast works without a problem. :D
That was wrong, i have one problem. From time to time FAST stops responding on the Ingame- Commands, but the proccess still runs in the background. The only chance to get the Ingame- Commands to work is restarting FAST. Is this a known bug from FAST?

*Edit*

Ok, its the same problem as here:

viewtopic.php?t=7617

I think this is a problem with php5 and 64 bit system, maybe the can fix this in the future...

User avatar
Slig
Pit Crew
Pit Crew
Posts: 2124
Joined: 05 Sep 2005 17:51
Owned TM-games: ALL
Location: TraxicoLand (Fr)
Contact:

Post by Slig » 16 Feb 2007 12:39

Fisch.666 wrote:I think this is a problem with php5 and 64 bit system, maybe the can fix this in the future...
:(
Did you tried with another php5 version ? or a php5 built on a 32bit system ?

v22 wrote: !!!!!! Connection Error !!!!!!
Warning in server.php(106): AuthWarning:
Warning in check_login_tm.php(88): Bad TMN Login Xtreme RA Team S2 !
Error in method_handler.php(226): Not Authenticated
I never tried with a login which contain spaces characters (mainly because i think that spaces have nothing to do in a login). Perhaps i'll try to see if it's possible to fix that on dedimania...

modbase
pedestrian
pedestrian
Posts: 13
Joined: 03 Feb 2007 13:20

Post by modbase » 16 Feb 2007 15:43

I can't use the admin commands :s
I've set my tmn login in the config, but i can't login as admin in FAST
Any help??

Paris69
speedy pilot
speedy pilot
Posts: 381
Joined: 05 Apr 2006 20:50

Post by Paris69 » 16 Feb 2007 15:54

in config? do you say ....xml.txt ?

and right formated?

Code: Select all

<adminlist>
	<player>
		<login>player1</login>
	</player>
	<player>
		<login>player2</login>
	</player>
	<player>
		<login>player3</login>
	</player>
        .
        .
        .

User avatar
----GLUK----
smooth traffic navigator
smooth traffic navigator
Posts: 199
Joined: 13 Feb 2006 20:11
Owned TM-games: all
Location: Russia
Contact:

Post by ----GLUK---- » 23 Feb 2007 05:59

[02/23,08:24:51] Connection to TM server: 127.0.0.1:5225
[02/23,08:24:51] ##############################################################
[02/23,08:24:51] An error occurred - -32300:transport error - could not open socket (error: 111, Connection refused)
[02/23,08:24:51]
[02/23,08:24:51] Can't connect to the TM server on xmlrpc port !
[02/23,08:24:51]
[02/23,08:24:51] Are you sure your server xmlrpc is on 127.0.0.1:5225 ? :roll:

User avatar
Slig
Pit Crew
Pit Crew
Posts: 2124
Joined: 05 Sep 2005 17:51
Owned TM-games: ALL
Location: TraxicoLand (Fr)
Contact:

Post by Slig » 23 Feb 2007 12:52

----GLUK---- wrote:[02/23,08:24:51] Connection to TM server: 127.0.0.1:5225
[02/23,08:24:51] ##############################################################
[02/23,08:24:51] An error occurred - -32300:transport error - could not open socket (error: 111, Connection refused)
[02/23,08:24:51]
[02/23,08:24:51] Can't connect to the TM server on xmlrpc port !
[02/23,08:24:51]
[02/23,08:24:51] Are you sure your server xmlrpc is on 127.0.0.1:5225 ? :roll:
verify the beginning of the Logs/ConsoleLog.xxxx.txt of your current dedicated process : the line "Listening for xml-rpc commands on port XXX" will permit you to verify if the port is really the good one (I suppose you launch fast on the same computer as your dedicated of course, or 127.0.0.1 is not good)

User avatar
NBAA
smooth traffic navigator
smooth traffic navigator
Posts: 239
Joined: 16 Oct 2005 16:58
Owned TM-games: TMO, TMS, TMU, TM²C
Manialink(s): nbaa / 2d2d

Post by NBAA » 24 Feb 2007 13:35

Hey, what happende to this excellent stat browser from the Fast records?
http://ns30909.ovh.net/~dedimani/tmstats/?do=stat
2D2DNBAA -> Too Drive to Drunk -> Join my server
My tracks@TmExchange: TMU / TMS / TMO / TMN / TM2

User avatar
Slig
Pit Crew
Pit Crew
Posts: 2124
Joined: 05 Sep 2005 17:51
Owned TM-games: ALL
Location: TraxicoLand (Fr)
Contact:

Post by Slig » 25 Feb 2007 12:36

NBAA wrote:Hey, what happende to this excellent stat browser from the Fast records?
http://ns30909.ovh.net/~dedimani/tmstats/?do=stat
i renamed the directory to avoid accesses because the server is too busy (it's actually the same on as this forum and carpark)

netid
highway camper
highway camper
Posts: 2
Joined: 08 Feb 2007 23:08

problems with fast

Post by netid » 25 Feb 2007 16:00

Hi!

I have a problem with fast.
I installed it but it does not store/retrieve records.
When I type \rec, I get no record avaible.
The console shows this:
[02/25,16:36:19] Loading plugins...
[02/25,16:36:19] ************* (db.0) *************
Dataserver connection on $l[http://dedimania.tm-community.com/tmstats/?do=stat]Dedimania$l ...
!!!!!!
!!!!!! Error no database response (http://ns30909.ovh.net/~dedimani/RPC3/server.php)
!!!!!!
[02/25,16:36:29] ------------- (db.0) -------------
Do you know another on-line database like http://ns30909.ovh.net/~dedimani/RPC3/server.php?
Do you know where I can find the scripts server.php and like so I could make my own database?
Do you know a plugin that would maintain a local database?

Thanks..

User avatar
----GLUK----
smooth traffic navigator
smooth traffic navigator
Posts: 199
Joined: 13 Feb 2006 20:11
Owned TM-games: all
Location: Russia
Contact:

Post by ----GLUK---- » 26 Feb 2007 01:17

F.A.S.T does not work for a week :(

User avatar
Slig
Pit Crew
Pit Crew
Posts: 2124
Joined: 05 Sep 2005 17:51
Owned TM-games: ALL
Location: TraxicoLand (Fr)
Contact:

Post by Slig » 26 Feb 2007 13:18

----GLUK---- wrote:F.A.S.T does not work for a week :(
Not really Fast but Dedimania... too long timeouts last 2 weeks on current server. I have problems with the database i bought some days ago, and have to resolve them before migrate dedimania. :(

User avatar
----GLUK----
smooth traffic navigator
smooth traffic navigator
Posts: 199
Joined: 13 Feb 2006 20:11
Owned TM-games: all
Location: Russia
Contact:

Post by ----GLUK---- » 05 Mar 2007 10:57

thx 4 new version slig :1010

Post Reply