ASECO/RASP v0.82 released!

Discuss everything about Xymph's Aseco flavoured server control scripts for TM Forever / classic TMN and for TM² Canyon.

Moderators: Xymph, TM-Patrol

User avatar
soehest
happy cruiser
happy cruiser
Posts: 161
Joined: 07 Jun 2007 13:52
Owned TM-games: TMU
Contact:

Re: ASECO/RASP v0.82 released!

Post by soehest » 18 Oct 2007 11:21

Running 0.82 now without any problems. Running together with theese plugins:

viewtopic.php?t=10172 (Offline messages)
viewtopic.php?t=6563 (AutotimeLimit)
viewtopic.php?f=28&t=10116 (MiniAdmin)
viewtopic.php?f=28&t=2527 (TMOS)
viewtopic.php?f=28&t=10461 (Matchsave) (Included in 0.8.2)

Everything seems to be working nicely.

And now on to the more serious bit (literally speaking :-))

I recently purchased a new server which is able to run 64 bit. I did some research before installing my operating system, mainly this thread:

tmforum3/viewtopic.php?f=28&t=7617

The problem seem to be when running under a 64 bit operating system the rpc calls to the server aren't working. But in the thread above there is a fix, but as seen in the thread this fix does not help everyone, and didn't help me as well.

Others have seem to have made some changes:
Fast created by slig text from GbxRemote.inc.php

Code: Select all

Release 2007-03-17 :
   Modified to support >256KB received data (and now >1MB data produce a specific error message)
   Modified readCB() to wait the initial timeout only before first read packet
   Modified readCB() to return true if there is data to get with getCBResponses()
   Modified to support amd64 <-------
   Modified IXR_ClientMulticall_Gbx->addCall() to fit Aseco 0.6.1
   Added IXR_Client_Gbx->bytes_sent and IXR_Client_Gbx->bytes_received counters
As seen modified to support amd64, but i didn't get this to work either, and didn't spend a lot of time as i wanted to get the machine into production and already knew i would run into more problems, so i reinstalled using 32 bit libs. I would though like to use 64 bit ;-) Are you or anyone else running this on a 64 bit system? Have tried? Had succes? Please share as i think it would be very nice to have this to run on a 64 bit system.

Regards
Daniel

Xymph
Pit Crew
Pit Crew
Posts: 5707
Joined: 19 Aug 2007 12:58
Owned TM-games: TMN, TMU, TMF, TM²
Contact:

Re: ASECO/RASP v0.82 released!

Post by Xymph » 18 Oct 2007 11:44

soehest wrote:Running 0.82 now without any problems. Running together with theese plugins:

viewtopic.php?t=10172 (Offline messages)
viewtopic.php?t=6563 (AutotimeLimit)
viewtopic.php?f=28&t=10116 (MiniAdmin)
viewtopic.php?f=28&t=2527 (TMOS)
viewtopic.php?f=28&t=10461 (Matchsave) (Included in 0.8.2)

Everything seems to be working nicely.
Ok great, thanks for the feedback, and to El Fuego too.
soehest wrote:As seen modified to support amd64, but i didn't get this to work either, and didn't spend a lot of time as i wanted to get the machine into production and already knew i would run into more problems, so i reinstalled using 32 bit libs. I would though like to use 64 bit ;-) Are you or anyone else running this on a 64 bit system? Have tried? Had succes? Please share as i think it would be very nice to have this to run on a 64 bit system.
I'm afraid I can't help there are I don't run (or have access to) a 64-bit server.

Xymph
Developer of XASECO for TMF/TMN ESWC & XASECO2 for TM²: see XAseco.org
Find your way around the Mania community from the TMN ESWC hub, TMF hub, TM² hub, and SM hub

User avatar
Fisch.666
happy cruiser
happy cruiser
Posts: 136
Joined: 18 May 2006 01:13
Owned TM-games: TMU, TMN, TMUF, TMNF
Location: Germany
Contact:

Re: ASECO/RASP v0.82 released!

Post by Fisch.666 » 18 Oct 2007 15:23

Hi!
soehest wrote:Running 0.82 now without any problems. Running together with theese plugins:

viewtopic.php?t=6563 (AutotimeLimit)
viewtopic.php?f=28&t=10116 (MiniAdmin)
viewtopic.php?f=28&t=2527 (TMOS)
Same here, all 3 plugin above and this one:

viewtopic.php?f=28&t=5779

are working without any problems with 0.82.

@soehest

Do you have compiled a new php installation with linux32 as i wrote here?

tmforum3/viewtopic.php?p=77917&sid=6a6b ... 893#p77917

User avatar
El Fuego
solid chaser
solid chaser
Posts: 1097
Joined: 27 Oct 2006 11:00
Owned TM-games: TMUF, TM2 C/S
Location: Nae too far frae Glesgie
Contact:

Re: ASECO/RASP v0.82 released!

Post by El Fuego » 18 Oct 2007 15:56

You're using my Team Chat plugin! :D

BTW - I now use Fufi's new Matchsave plugin that incorporates teamchat.
Cheers!
.FUEY.
Diary Of A Mad Man

cow
smooth traffic navigator
smooth traffic navigator
Posts: 216
Joined: 20 Mar 2007 02:53
Owned TM-games: TMU, TMS, TMO
Contact:

Re: ASECO/RASP v0.82 released!

Post by cow » 20 Oct 2007 17:26

fast 3.1.3e works for me.. with the dedi info.
besides for what el fuego uses and his chatbot
i use bestrecs global stats, atm,(both time and track) and better karma* and admin join (required no work)
nochat
slly votes
mini admin
juke credits
(requires a bit of work)

*well this required quite a bit of rok but that is because i foolishly call karma.. cowma
join me at the music tower
Tet19's MusicTower

Ohebukki
pedestrian
pedestrian
Posts: 10
Joined: 21 Oct 2007 23:29
Owned TM-games: TMN,TMU

Re: ASECO/RASP v0.82 released!

Post by Ohebukki » 21 Oct 2007 23:47

sbone wrote:I found my error, mistake to me ;)
Thanks
Hi sbone- i have nearly the same error-with this :


[Local DB] Load settings file ...
[Local DB] Try to connect to MySQL server
[Local DB] MySQL Server Version is 5.0.45-community-nt
[RASP] Cleaning up unused data
*-*-*-*-*-* RASP is running! *-*-*-*-*-*
|...Loading Settings
|...Loaded!
|...Checking database structure
|...Structure OK!
|...Calculating ranks
|...Done!
[10/22,01:17:11] [Client] init: OK
[RASP] Error - TMX Directory (ArrayChallenges/TMX) does not exist
[RASP] Error - TMX Directory (ArrayChallenges/TMX) can not be written to
###############################################################################
Aseco v0.82 Xymph running on 127.0.0.1:5000
Game : TmNationsESWC - Rounds
Author: Florian Schnell
Re-Authored: Assembler Maniac & Xymph
###############################################################################
Begin Race
[RPC Error -1000] Permission denied.
[RPC Error -1000] Permission denied.
[RPC Error -1000] Permission denied.
............................................ (nearly 40 times again)


But U found the mistake ! :shock: Me not !!

Can U (or any other - (Xymph) ) help me please-what must i change ? (Runs on Windows XP Prof.-new formatted Harddisk/brand new)

Thx, Ohebukki
Last edited by Ohebukki on 22 Oct 2007 14:12, edited 2 times in total.

User avatar
soehest
happy cruiser
happy cruiser
Posts: 161
Joined: 07 Jun 2007 13:52
Owned TM-games: TMU
Contact:

Re: ASECO/RASP v0.82 released!

Post by soehest » 22 Oct 2007 10:50

Fisch.666 wrote:Hi!
soehest wrote:Running 0.82 now without any problems. Running together with theese plugins:

@soehest

Do you have compiled a new php installation with linux32 as i wrote here?

tmforum3/viewtopic.php?p=77917&sid=6a6b ... 893#p77917
I must admit i did not try this approach as it seemed to be a bit complicated using gentoo as my dist but will look further into this when i get the time to set up a test box, thanx :-)

Regards

Xymph
Pit Crew
Pit Crew
Posts: 5707
Joined: 19 Aug 2007 12:58
Owned TM-games: TMN, TMU, TMF, TM²
Contact:

Re: ASECO/RASP v0.82 released!

Post by Xymph » 22 Oct 2007 16:05

Ohebukki wrote:Hi sbone- i have nearly the same error-with this :

[Local DB] Load settings file ...
[Local DB] Try to connect to MySQL server
[Local DB] MySQL Server Version is 5.0.45-community-nt
[RASP] Cleaning up unused data
*-*-*-*-*-* RASP is running! *-*-*-*-*-*
|...Loading Settings
|...Loaded!
|...Checking database structure
|...Structure OK!
|...Calculating ranks
|...Done!
[10/22,01:17:11] [Client] init: OK
[RASP] Error - TMX Directory (ArrayChallenges/TMX) does not exist
[RASP] Error - TMX Directory (ArrayChallenges/TMX) can not be written to
###############################################################################
Aseco v0.82 Xymph running on 127.0.0.1:5000
Game : TmNationsESWC - Rounds
Author: Florian Schnell
Re-Authored: Assembler Maniac & Xymph
###############################################################################
Begin Race
[RPC Error -1000] Permission denied.
[RPC Error -1000] Permission denied.
[RPC Error -1000] Permission denied.
............................................ (nearly 40 times again)


But U found the mistake ! :shock: Me not !!

Can U (or any other - (Xymph) ) help me please-what must i change ? (Runs on Windows XP Prof.-new formatted Harddisk/brand new)
In config.xml in the <tmserver> section, do you have <password>YOUR_ADMIN_PASSWORD</password> set to your admin password (the same as in the TMN server's dedicated.cfg)?
In localdatabase.xml do you have <mysql_login> and <mysql_password> set to your MySQL account/password?

Xymph
Developer of XASECO for TMF/TMN ESWC & XASECO2 for TM²: see XAseco.org
Find your way around the Mania community from the TMN ESWC hub, TMF hub, TM² hub, and SM hub

Ohebukki
pedestrian
pedestrian
Posts: 10
Joined: 21 Oct 2007 23:29
Owned TM-games: TMN,TMU

Re: ASECO/RASP v0.82 released!

Post by Ohebukki » 23 Oct 2007 16:02

Xymph wrote:
Ohebukki wrote:Hi sbone- i have nearly the same error-with this :

[Local DB] Load settings file ...
[Local DB] Try to connect to MySQL server
[Local DB] MySQL Server Version is 5.0.45-community-nt
[RASP] Cleaning up unused data
*-*-*-*-*-* RASP is running! *-*-*-*-*-*
|...Loading Settings
|...Loaded!
|...Checking database structure
|...Structure OK!
|...Calculating ranks
|...Done!
[10/22,01:17:11] [Client] init: OK
[RASP] Error - TMX Directory (ArrayChallenges/TMX) does not exist
[RASP] Error - TMX Directory (ArrayChallenges/TMX) can not be written to
###############################################################################
Aseco v0.82 Xymph running on 127.0.0.1:5000
Game : TmNationsESWC - Rounds
Author: Florian Schnell
Re-Authored: Assembler Maniac & Xymph
###############################################################################
Begin Race
[RPC Error -1000] Permission denied.
[RPC Error -1000] Permission denied.
[RPC Error -1000] Permission denied.
............................................ (nearly 40 times again)


But U found the mistake ! :shock: Me not !!

Can U (or any other - (Xymph) ) help me please-what must i change ? (Runs on Windows XP Prof.-new formatted Harddisk/brand new)
In config.xml in the <tmserver> section, do you have <password>YOUR_ADMIN_PASSWORD</password> set to your admin password (the same as in the TMN server's dedicated.cfg)?
In localdatabase.xml do you have <mysql_login> and <mysql_password> set to your MySQL account/password?

Xymph
In config.xml <tmserver> section- there is the error i think- because i really dont know what i have to write at the end of this ! - <account> !??
Which account i had to write inside this ??

Xymph
Pit Crew
Pit Crew
Posts: 5707
Joined: 19 Aug 2007 12:58
Owned TM-games: TMN, TMU, TMF, TM²
Contact:

Re: ASECO/RASP v0.82 released!

Post by Xymph » 23 Oct 2007 17:33

Ohebukki wrote:
Xymph wrote:In config.xml in the <tmserver> section, do you have <password>YOUR_ADMIN_PASSWORD</password> set to your admin password (the same as in the TMN server's dedicated.cfg)?
In localdatabase.xml do you have <mysql_login> and <mysql_password> set to your MySQL account/password?
In config.xml <tmserver> section- there is the error i think- because i really dont know what i have to write at the end of this ! - <account> !??
Which account i had to write inside this ??
The same account as entered in dedicated.cfg, section <masterserver_account>, field <login>.
But that wouldn't cause the kind of errors you're having anyway, so the problem must be somewhere else.
You could try deleting everything and installing the new v0.84 from scratch.

Xymph
Developer of XASECO for TMF/TMN ESWC & XASECO2 for TM²: see XAseco.org
Find your way around the Mania community from the TMN ESWC hub, TMF hub, TM² hub, and SM hub

User avatar
soehest
happy cruiser
happy cruiser
Posts: 161
Joined: 07 Jun 2007 13:52
Owned TM-games: TMU
Contact:

Re: ASECO/RASP v0.82 released!

Post by soehest » 24 Oct 2007 00:54

soehest wrote:Running 0.82 now without any problems. Running together with theese plugins:

viewtopic.php?f=28&t=2527 (TMOS)
I really don't know if its normal to reply to your own posts, you may hit me if i am doing something wrong :-) TMOS still has random crashes which will tear down aseco as well. This has been reported to the author of tmos.

Regards

Post Reply