[Tutorial] Setting up your ASECO server (local database)

Answers to the most commonly asked questions with both user created and official tutorials

Moderator: TM-Patrol

TRY-_-ME
pedestrian
pedestrian
Posts: 9
Joined: 13 May 2007 21:00
Contact:

Post by TRY-_-ME » 14 Jun 2007 12:46

any one tried this? :shock: ... i tried it by my self not helping!!!!!!!! :? :? :? :? :? :evil: :evil: :evil: :evil:

[RFR]Pain
highway camper
highway camper
Posts: 1
Joined: 06 Aug 2007 10:41
Owned TM-games: TMN

Re:

Post by [RFR]Pain » 07 Aug 2007 19:13

w00pz wrote:hey
i get this error, what have i done wrong?

PHP Fatal error: Call to undefined function mysql_connect() in C:\Program Files
\TrackMania Nations ESWC\aseco\plugins\plugin.localdatabase.php on line 59
Press any key to continue . . .
i have exactly the same error. But apparently no one knows a solution to this, as I couldn't find one. i would gladly use public database as an alternative, but there is no tutorial to how to set a public database. Well, there is one that Flo has written, but with all due respect, the tutorial is very difficult to understand. And it also has a lot to do with http://www.tmbase.de, which is probably the most confusing site I have ever visited in...

UKFC»ACE
smooth traffic navigator
smooth traffic navigator
Posts: 203
Joined: 08 Jun 2007 19:50
Owned TM-games: TMUF, TMNF
Location: Dublin, IRELAND

Re: [Tutorial] Setting up your ASECO server (local database)

Post by UKFC»ACE » 09 Aug 2007 08:10

Are you using the latest version of xampp??? It won't work with the latest version.... use this one... xampp-win32-1.5.4a-installer.exe

Manaaja
highway camper
highway camper
Posts: 2
Joined: 25 May 2007 17:58
Contact:

Re: [Tutorial] Setting up your ASECO server (local database)

Post by Manaaja » 11 Sep 2007 19:04

i got this problem now......


# initialize ASECO ############################################################
[Aseco] PHP Version is 5.1.6
[Aseco] Load settings [config.xml]
[Aseco] Load plugin [plugin.localdatabase.php]
[Aseco] Load plugin [chat.admin.php]
[Aseco] Load plugin [chat.help.php]
[Aseco] Load plugin [chat.me.php]
[Aseco] Load plugin [chat.records.php]
[Aseco] Load plugin [chat.stats.php]
[Aseco] Load plugin [chat.players.php]
[Aseco] Load plugin [chat.tmchat.php]
[Aseco] Load plugin [plugin.rasp.php]
[Aseco] Load plugin [plugin.rasp_jukebox.php]
[Aseco] Load plugin [plugin.rasp_chat.php]
[Aseco] Load plugin [plugin.rasp_karma.php]
[Aseco] Load plugin [plugin.rasp_nextmap.php]
[Aseco] Load plugin [plugin.adminjoin.php]
[Aseco] Load plugin [plugin.joinleave.php]
[Aseco] Try to connect to server on 127.0.0.1:5000
[Aseco] Authenticated with username 'SuperAdmin' and password '****'
[Aseco] Connection established successfully!
[Local DB] Load settings file ...
[Local DB] Try to connect to MySQL server
[PHP Warning] mysql_connect(): Access denied for user '****'@'localhost' (using
password: YES) on line 63 in file C:\Aseco\plugins\plugin.localdatabase.php
[ASECO Error] [Local DB] Could not authenticate at MySQL server! on line 64

It come about 2 days a go......before that it worked perfectly!!!

I didn't change anything

Ch41r
pedestrian
pedestrian
Posts: 6
Joined: 18 Jul 2007 20:31
Contact:

Re: [Tutorial] Setting up your ASECO server (local database)

Post by Ch41r » 04 Oct 2007 15:25

I tried following this tutorial which by the way was easy and nice to figure out, but ended up with this problem... Can1 please help? I'm already using the newest version of the dedicated server..

# initialize ASECO ############################################################
[Aseco] Load settings [config.xml]
[Aseco] Load plugin [chat.admin.php]
[Aseco] Load plugin [chat.help.php]
[Aseco] Load plugin [chat.me.php]
[Aseco] Load plugin [chat.records.php]
[Aseco] Load plugin [chat.stats.php]
[Aseco] Load plugin [chat.vote.php]
[Aseco] Load plugin [plugin.localdatabase.php]
[Aseco] Try to connect to server on 127.0.0.1:5000
[Aseco] Authenticated with username 'SuperAdmin' and password '*************'
[Aseco] Connection established successfully!
[Local DB] Load settings file ...
[Local DB] Try to connect to MySQL server
[Local DB] Synchronize players with database
###############################################################################
# Aseco v0.6.1b running on 127.0.0.1:5000
# Game : TmNationsESWC - TimeAttack
# Author: Florian Schnell
###############################################################################
[RPC Error -1000] Permission denied.
Array
(
[0] => CleanChatCommand
[1] => Array
(
)

)
[RPC Error -1000] Permission denied.
Array
(
[0] => AddChatCommand
[1] => Array
(
[0] => admin
)

)
[RPC Error -1000] Permission denied.
Array
(
[0] => AddChatCommand
[1] => Array
(
[0] => help
)

)
[RPC Error -1000] Permission denied.
Array
(
[0] => AddChatCommand
[1] => Array
(
[0] => me
)

)
[RPC Error -1000] Permission denied.
Array
(
[0] => AddChatCommand
[1] => Array
(
[0] => recs
)

)
[RPC Error -1000] Permission denied.
Array
(
[0] => AddChatCommand
[1] => Array
(
[0] => stats
)

)
[RPC Error -1000] Permission denied.
Array
(
[0] => AddChatCommand
[1] => Array
(
[0] => vote
)

)
[RPC Error -1000] Permission denied.
Array
(
[0] => AddChatCommand
[1] => Array
(
[0] => score
)

)
[RPC Error -1000] Permission denied.
Array
(
[0] => ChatSendServerMessage
[1] => Array
(
[0] => $ff0*** Aseco $fffv0.6.1b$ff0 running on $fff127.0.0.1$ff0:$f
ff5000$ff0 ***
)

)
[10/04,17:22:10] map changed [none] >> [loop D' loop2]
[10/04,17:22:10] no votings available for this track
[10/04,17:22:10] current record on loop D' loop2 is 96500 and held by trut
[10/04,17:22:35] << player 141 joined the game [wiiking]

as it is by the moment the server is not displaying any info on the server when playing the tracks?!

what causes theese rpc -1000 errors?

Burkman
highway camper
highway camper
Posts: 1
Joined: 30 Oct 2007 08:50
Owned TM-games: TMN

Re: [Tutorial] Setting up your ASECO server (local database)

Post by Burkman » 04 Nov 2007 19:31

Hi all.. I also seem to be having some problems :P

Everything should be set right since I followed the tutorial and tried with creating a new user at my phpserver.
But at first when I try to launch aseco there's a message displayed that says that a file called "MSVCR71.dll" can't be found. That message disappears when I close down the Error window three times, and when I've one so, following error occurs:

-------------------------------

PHP Warning: PHP Startup: Unable to load dynamic library 'C:\Program\xampp\php\
ext\php_mysql.dll' - The module can't be found (the MSV-problem)
in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library 'C:\Program\xampp\php\
ext\php_mysqli.dll' - The module can't be found (again)
in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library 'C:\Program\xampp\php\
ext\php_openssl.dll' - The module can't be found (and again)
in Unknown on line 0
# initialize ASECO ############################################################
[Aseco] PHP Version is 5.1.6
[Aseco] Load settings [config.xml]
[Aseco] Load plugin [plugin.localdatabase.php]
[Aseco] Load plugin [plugin.rounds.php]
[Aseco] Load plugin [chat.admin.php]

[Aseco] Load plugin [chat.help.php]
[Aseco] Load plugin [chat.records.php]
[Aseco] Load plugin [chat.records2.php]
[Aseco] Load plugin [chat.recrels.php]
[Aseco] Load plugin [chat.players.php]
[Aseco] Load plugin [chat.players2.php]
[Aseco] Load plugin [chat.wins.php]
[Aseco] Load plugin [chat.stats.php]
[Aseco] Load plugin [chat.server.php]
[Aseco] Load plugin [chat.me.php]
[Aseco] Load plugin [plugin.track.php]
[Aseco] Load plugin [plugin.rasp.php]
[Aseco] Load plugin [plugin.rasp_jukebox.php]
[Aseco] Load plugin [plugin.rasp_chat.php]
[Aseco] Load plugin [plugin.rasp_karma.php]
[Aseco] Load plugin [plugin.rasp_nextmap.php]
[Aseco] Load plugin [plugin.rasp_nextrank.php]
[Aseco] Load plugin [plugin.rasp_votes.php]
[Aseco] Load plugin [plugin.chatlog.php]
[Aseco] Load plugin [plugin.uptodate.php]
[Aseco] Load plugin [jfreu.plugin.php]
[Aseco] Load plugin [mistral.idlekick.php]
[Aseco] Load plugin [plugin.localdatabase.php]
[Aseco] Try to connect to server on 127.0.0.1:5000
[Aseco] Authenticated with username 'SweET_' and password '******'
[Aseco] Connection established successfully!
[Local DB] Load settings file ...
[Local DB] Try to connect to MySQL server

Fatal error: Call to undefined function mysql_connect() in C:\Program\TrackMania
Nations ESWC\aseco_rasp_086\plugins\plugin.localdatabase.php on line 69
Press key of your choice to continue

-------------------------------------

Would be nice with some help.. It's probably the same problem that everyone else been having.. But I just can't find a working solution ^^
Cheers

>WP<Weedy
highway camper
highway camper
Posts: 3
Joined: 12 Nov 2007 10:16
Owned TM-games: TMN, TMU

Re: Re:

Post by >WP<Weedy » 12 Nov 2007 10:20

[RFR]Pain wrote:
w00pz wrote:hey
i get this error, what have i done wrong?

PHP Fatal error: Call to undefined function mysql_connect() in C:\Program Files
\TrackMania Nations ESWC\aseco\plugins\plugin.localdatabase.php on line 59
Press any key to continue . . .
i have exactly the same error. But apparently no one knows a solution to this, as I couldn't find one. i would gladly use public database as an alternative, but there is no tutorial to how to set a public database. Well, there is one that Flo has written, but with all due respect, the tutorial is very difficult to understand. And it also has a lot to do with http://www.tmbase.de, which is probably the most confusing site I have ever visited in...
change in Aseco.sh
php to php5

Worked for us.

e6r6i6c
pedestrian
pedestrian
Posts: 8
Joined: 18 Nov 2007 00:32
Owned TM-games: TMN

Re: [Tutorial] Setting up your ASECO server (local database)

Post by e6r6i6c » 18 Nov 2007 00:51

I got aseco to work, but it is not displaying anything on the server it self, it records the time, the database is working, but ingame aseco does not show up. any suggestions???

This is the error I get when running aseco:

# initialize ASECO ############################################################
[Aseco] PHP Version is 5.1.6
[Aseco] Load settings [config.xml]
[Aseco] Load admin/ops lists [adminops.xml]
[Aseco] Load plugin [plugin.localdatabase.php]
[Aseco] Load plugin [plugin.rounds.php]
[Aseco] Load plugin [chat.admin.php]

[Aseco] Load plugin [chat.help.php]
[Aseco] Load plugin [chat.records.php]
[Aseco] Load plugin [chat.records2.php]
[Aseco] Load plugin [chat.recrels.php]
[Aseco] Load plugin [chat.players.php]
[Aseco] Load plugin [chat.players2.php]
[Aseco] Load plugin [chat.wins.php]
[Aseco] Load plugin [chat.stats.php]
[Aseco] Load plugin [chat.server.php]
[Aseco] Load plugin [chat.me.php]
[Aseco] Load plugin [plugin.track.php]
[Aseco] Load plugin [plugin.rasp.php]
[Aseco] Load plugin [plugin.rasp_jukebox.php]
[Aseco] Load plugin [plugin.rasp_chat.php]
[Aseco] Load plugin [plugin.rasp_karma.php]
[Aseco] Load plugin [plugin.rasp_nextmap.php]
[Aseco] Load plugin [plugin.rasp_nextrank.php]
[Aseco] Load plugin [plugin.rasp_votes.php]
[Aseco] Load plugin [plugin.chatlog.php]
[Aseco] Load plugin [plugin.uptodate.php]
[Aseco] Load plugin [jfreu.plugin.php]
[Aseco] Load plugin [mistral.idlekick.php]
[Aseco] Try to connect to server on 127.0.0.1:5001
[Aseco] Authenticated with username 'e6r6i6c1' and password 'welkom666'
[Aseco] Connection established successfully!
[Local DB] Load settings file ...
[Local DB] Try to connect to MySQL server
[Local DB] MySQL Server Version is 5.0.24a-community-nt
[RASP] Cleaning up unused data
*-*-*-*-*-* RASP is running! *-*-*-*-*-*
|...Loading Settings
|...Loaded!
|...Checking database structure
|...Structure OK!
|...Calculating ranks
|...Done!
[RASP] Error - TMX Directory (ArrayChallenges/TMX) does not exist
[RASP] Error - TMX Directory (ArrayChallenges/TMX) can not be written to
###############################################################################
Aseco v0.89 Xymph running on 127.0.0.1:5001
Game : TmNationsESWC - TimeAttack
Author: Florian Schnell
Re-Authored: Assembler Maniac & Xymph
###############################################################################
Begin Race
[RPC Error -1000] Permission denied.
Array
(
[0] => ChatSendServerMessage
[1] => Array
(
[0] => $z$s$ff0>> $z$s$fffJfreu$z$s$39f's plugin $z$s$ff00.13d$z$s$3
9f: $z$s$fffLoaded$z$s$39f.
)

)
[RPC Error -1000] Permission denied.
Array
(
[0] => ChatSendServerMessage
[1] => Array
(
[0] => $z$s$ff0>> $z$s$39fRankLimit: $z$s$fffOFF$z$s$39f.
)

)
[11/18,03:21:49] track changed [none] >> [Warmup!]
[11/18,03:21:49] current record on Warmup! is 0:57.81 and held by e6r6i6c1
End Race
|...Calculating ranks
|...Done!
Begin Race
[11/18,03:25:50] track changed [Warmup!] >> [CID1]
[11/18,03:25:50] currently no record on CID1
Begin Round
[11/18,03:26:30] << player 2 joined the game [doingk : -=[C.I.D.]=- DoingK : NED
: 67341 : 77.249.232.104]
End Race
|...Calculating ranks
|...Done!
End Round
Begin Round
[11/18,03:28:26] [Local DB] player doingk finished with 49410 and took the 1. LR
place!
[11/18,03:28:50] >> player 2 left the game [doingk : -=[C.I.D.]=- DoingK]

Xymph
Pit Crew
Pit Crew
Posts: 5652
Joined: 19 Aug 2007 12:58
Owned TM-games: TMN, TMU, TMF, TM²
Contact:

Re: [Tutorial] Setting up your ASECO server (local database)

Post by Xymph » 18 Nov 2007 11:10

e6r6i6c wrote:I got aseco to work, but it is not displaying anything on the server it self, it records the time, the database is working, but ingame aseco does not show up. any suggestions???
Check your rasp.xml file for typos and mismatched tags. Also check the <tmserver> section in your config.xml for matching info to the TMN server's dedicated.cfg.
Developer of XASECO for TMF/TMN ESWC & XASECO2 for TM²: see XAseco.org
Find your way around the Mania community from the TMN ESWC hub, TMF hub, TM² hub, and SM hub

e6r6i6c
pedestrian
pedestrian
Posts: 8
Joined: 18 Nov 2007 00:32
Owned TM-games: TMN

Re: [Tutorial] Setting up your ASECO server (local database)

Post by e6r6i6c » 18 Nov 2007 14:00

I solved the problem, I read it on a german forum, I changed the superadmin login name, I should not have done that, leave the superadmin login name, only enter another pasword, match this in the aseco file and then it should work.

Everything is working now :mrgreen:

RAstaboy
highway camper
highway camper
Posts: 2
Joined: 27 Nov 2007 09:11
Owned TM-games: TMN

Re: [Tutorial] Setting up your ASECO server (local database)

Post by RAstaboy » 27 Nov 2007 10:42

HELP ME PLS!!!! Cant understend what i did wrong :(
My tools in Windows:
mysql-4.1.22-win32
php-5.2.5-Win32
aseco_rasp_089

Code: Select all

# initialize ASECO ############################################################
[Aseco] PHP Version is 5.2.5
[Aseco] Load settings [config.xml]
[Aseco] Load admin/ops lists [adminops.xml]
[Aseco] Load plugin [plugin.localdatabase.php]
[Aseco] Load plugin [plugin.rounds.php]
[Aseco] Load plugin [chat.admin.php]

[Aseco] Load plugin [chat.help.php]
[Aseco] Load plugin [chat.records.php]
[Aseco] Load plugin [chat.records2.php]
[Aseco] Load plugin [chat.recrels.php]
[Aseco] Load plugin [chat.players.php]
[Aseco] Load plugin [chat.players2.php]
[Aseco] Load plugin [chat.wins.php]
[Aseco] Load plugin [chat.stats.php]
[Aseco] Load plugin [chat.server.php]
[Aseco] Load plugin [chat.me.php]
[Aseco] Load plugin [plugin.track.php]
[Aseco] Load plugin [plugin.rasp.php]
[Aseco] Load plugin [plugin.rasp_jukebox.php]
[Aseco] Load plugin [plugin.rasp_chat.php]
[Aseco] Load plugin [plugin.rasp_karma.php]
[Aseco] Load plugin [plugin.rasp_nextmap.php]
[Aseco] Load plugin [plugin.rasp_nextrank.php]
[Aseco] Load plugin [plugin.rasp_votes.php]
[Aseco] Load plugin [plugin.chatlog.php]
[Aseco] Load plugin [plugin.uptodate.php]
[Aseco] Load plugin [jfreu.plugin.php]
[Aseco] Load plugin [mistral.idlekick.php]
[Aseco] Try to connect to server on 127.0.0.1:5225
[Aseco] Authenticated with username 'SuperAdmin' and password '*******'
[Aseco] Connection established successfully!
[Local DB] Load settings file ...
[Local DB] Try to connect to MySQL server

Fatal error: Call to undefined function mysql_connect() in E:\tm-server\aseco\pl
ugins\plugin.localdatabase.php on line 69
Press any key to continue . . .

User avatar
f*ckfish
Pit Crew
Pit Crew
Posts: 1302
Joined: 15 Jun 2007 07:59
Owned TM-games: TMNF, TMUF
Location: Dresden, Germany
Contact:

Re: [Tutorial] Setting up your ASECO server (local database)

Post by f*ckfish » 27 Nov 2007 13:36

It looks like you did not include the php-mysql extensions in your php.ini file.
there should be a line in the php.ini you have to uncomment like this:

Code: Select all

// MySQL extension
extension=php_mysql.dll
(if the line does not exist, just create it and see what happens ;-)

If it doesn't work, uninstall everything and download xampp, that's preconfigured =)
inactive, sorry

Underlinge
highway camper
highway camper
Posts: 1
Joined: 16 Dec 2007 14:22
Owned TM-games: TMN

Re: [Tutorial] Setting up your ASECO server (local database)

Post by Underlinge » 16 Dec 2007 16:04

Everything works fine, but theres one small problem.
I can't get on my srever! Anyone has an idea why?

I cannot see the server in browser too, but my friend can.

User avatar
Clinton
smooth traffic navigator
smooth traffic navigator
Posts: 241
Joined: 26 Jan 2008 20:56
Owned TM-games: TMU, TMN, TMO
Location: Dripping Springs, Texas
Contact:

Re: [Tutorial] Setting up your ASECO server (local database)

Post by Clinton » 31 Jan 2008 10:50

I set the php path to C:/xampp/php because that's where it is located on my computer, and when I try to run the Aseco.bat it gives me an error. Enviroment variable C://xampp/php not defined '"\php.exe"' is not recogonized as an internal or external command, Press and key to continue . . . Can anyone help me, please?
Image

http://allgamer.net cheapest Trackmania server hosting with the best support. We also do VPS hosting, Dedicated Servers, and Web Hosting! Request a free 3 day trial for a VPS

clinton@teameo.net for more information.

gedis987
highway camper
highway camper
Posts: 1
Joined: 24 Feb 2008 22:03
Owned TM-games: TMN

Re: [Tutorial] Setting up your ASECO server (local database)

Post by gedis987 » 24 Feb 2008 22:08

Open a browser window (Internet Explorer, firefox, etc) and enter the address: http://localhost (Or just click here!) my browser opens nothing, a blank page. what's the problem?

Post Reply